Kom i gang med Flash MX

Åbn Flash MX. Standard (default) skærmbilledet ses her:
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Hvis skærmbilledet ikke ser sådan ud kan du altid grundindstille ved at vælge

Window > Panel Set > Default Layout

Det kan du selvfølge også gøre hvis du har flyttet rundt på de forskellige vinduer.

Du kan flytte vinduer ved at trække i den prikkede del af devenstre, øverste hjørne:
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Gem din movie nu under et navn – for eksempel komIgang.fla
OBS: Husk at gemme din Movie jævnligt!
Her er et udsnit af skærmbilledet med de vigtigste vinduer:
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I øverste, venstre hjørne ses Tools, som rummer de værktøjer hvormed du kan skabe og modificere grafik og tekst. Du vælger et værktøj ved at klikke på det. Nederst på værktøjspanelet findes andre værktøjer, der kan modificere billedstørrelser og farver. 

Timeline med en række enkeltfelter der kaldes frames ses øverst. Her skabes for eksempel  sekvenser for en animation. Kan sammenlignes med enkeltbilleder i en film.

Stage er det hvide firkantede felt midt på skærmen. Her skaber du din Movie.

Properties er feltet nederst i billedet, her indstilles forskellige egenskaber ved den endelige Flash-movie.

Her kan du bestemme

Size
  Stage-format, som svarer til den endelige Flash-moviesbredde og højde i pixels. 

Publish     
  hvor du kan vælge om din movie skal gemmes i en tidliger Flash-versions format.

Background
  hvor du kan vælge Stage baggrundsfarve.

Frame Rate   hvor du kan vælge afspilningshastigheden af movie’en i frames per sekund 

  – for eksempel af en animation.

I det følgende bliver mange grundlæggende egenskaber og funktionerne i Flash MX gennemgået.

En Flash-movie med animation og lyd.

Vælge: Modify > Document (eller Ctrl + M )
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Her får du lidt flere egenskaber at vælge imellem end i standard Properties-vinduet.

SkrivPRIVATE
 5 ud for Frame Rate. 

Skriv 400 px ud for (width)

Skriv 400 px ud for (height) 

Klik i Background Color og vælg hvid. 

Vælg Pixels fra Ruler Unit’s drop-down menu. 

Klik OK.

Du skal først skabe en grafik. Grid-værktøjet er fornuftig at bruge til dette formål. 

Vælg View > Grid > Edit Grid  eller Ctrl + Alt + G
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Klik i farveboksen og vælg en grå farve, så Grid (netværket) ses som grå.

Sæt flueben i  Show Grid for at se Grid på Stage. 

Sæt flueben i Snap to Grid så det grafiske omrids matcher gitterlinierne

Sæt det horisontale felt til 20 px for at separere horisontale linier med 20 pixels.

Sæt det vertikale felt til 20 px for at separere vertikale linier med 20 pixels.

Vælg Snap Accuracy: Normal og klik OK

Stage ser nu således ud:
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Du skal nu bruge Cirkel værktøjet til at tegne en ellipse. Dernæst skal ellipsen omdannes til et Symbol.

Symboler fungerer som genbrugsgrafik der gemmes i et Library (Bibliotek). 

Senere kan du bruge ellipsen på andre måder – for eksempel til den knap der starter Movien.

Tegn ellipsen:

Vælg View > Antialias (Ctrl+Alt+Shift+A) fra menu’en. - antialias opbløder tegningens kanter. 

Vælg Oval Tool. 

To farve-felter ses længere nede i  Modifier panelet. 

Disse farve-felter bruges til at sætte omrids- (Stroke) og udfyldnings- (Fill) farververne. 
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Linietykkelse sættes i  Properties nederst på skærmen:
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Skriv 3 i  Vertikal for at sætte linietykkelsen.

Klik på  Stroke color box og vælg sort. 

Klik på Fill color box og vælg en dyb blå farve. 

Klik på Stage og træk diagonalt for at tegne en ellipse.

Du skal nu ændre din grafik (ellipsen) til et symbol og gemme grafikken i Library. 

Emner som findes i Library kan bruges og genbruges senere.
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Vælg Pile-værktøjet.
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Dobblet-klik på elipsen.

Ovalen markeres og frame 1 i Timeline fremhæves som vist her:
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Højreklik på ovalen og vælg Convert to Symbol fra menu’en.  

Convert to Symbol vinduet åbnes:
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Skriv Start Knap i  Name feltet. 

Vælg Button som Behavior. 

Klik OK. 

Vælg Window > Library fra menu’en. Library panel åbnes. Du kan nu se Start Knap i Library vinduet og hvis du klikker på ikonet vises knappen i billedfeltet oven over.
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Klik Delete på tastaturet for at fjerne ellipsen fra  Stage – nu har du jo en kopi af Start Knap i Library.

Bemærk: Når et panel er åbnet (for eksempel, Library eller  Stroke panel) kan du lade det være åbent til senere brug.

Hvis et eller flere paneler er til gene for dig kan du bruge TAB-tasten til at vise og gemme panelerne.

Klik på TAB-tasten. Library panelet (og Stroke panelet hvis det er åbnet) forsvinder. 

Klik atter på TAB-tasten og begge paneler kommer til syne.

Gradienter
Når du klikker på  Fill Color box vil Fill dialog box åbnes.
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Gradienter vises i nederste række og viser farvegradueringer. 

Du kan benytte en gradient til at skabe en himmel for eksempel, men du skal først vælge den gradient du vil bruge.

 Vælg Window > Color Mixer – hvis den ikke er fremme.
Vælg Linear Gradient fra drop-down menu’en. Klik på Color Box. En farve box bliver synlig:
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Klik på  Edit Gradient Range ikonet til venstre og vælg en blå farve. 

Klik på Edit Gradient Range ikonet til højre og vælg hvid.

Flyt den anden Edit Gradient Range ikon til en stilling som på ovenstående figur (cirka trekvart af gradientforløbet) – det giver mere hvidt i gradientens forløb.

Rektangel-værktøjet

Dette værktøj bruges til at tegne rektangler og kvadrater. I denne øvelse skaber du et rektangel og fylder det med gradienten du netop har skabt.. Dernæst skal grafikken ændres til et symbol og senere skal den bruges til at skabe himlen.

Vælg Rektangel-værktøjet.
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Gå til Stroke panelet. Hvis det ikke er åbnet vælger du Window > Panels > Stroke fra menu’en. 

I Stroke Panel vælges Hairline fra drop-down menu’en. I Stroke Color box vælges sort. 

I Fill Color box vælges gradienten du skabte.
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Klik på Stage og træk diagonalt for at danne et rektangel.

Vælg hele figuren ved at føre pile-værktøjet rundt om figuren.

Du skal bruge denne grafik senere. Lige nu skal grafikken ændres til et symbol.

Højreklik og vælg Convert to Symbol

Skriv Himmel i Name feltet. Vælg Graphic som Behavior som her:
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Klik på OK for at gemme grafikken i Library. 

Tast Delete for at fjerne grafikken fra Stage. 

Blyant værktøj

Dette værktøj skal bruges til at tegne frihåndstegninger. Du skal tegne en træstamme og en trætop.

Lav stammen
Vælg View >. Fravælg Snap to Objects

Vælg blyanten. 
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Klik på Stroke Color box og vælg en brun farve. 

Klik på Fill Color box og vælg Solid og den samme brune farve. 

Vælg Smooth på Modifier panel’et. 

Denne valgmulighed afrunder (udglatter) din tegnings hjørner. 
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Tegn træstammen som her:

Husk at gemme din Movie!
Vælg Malerspand-værktøjet, som kan udfylde felter der er omgivet af linier i et lukket felt. 
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Klik inde i tegningen af stammen med malerspand-værktøjet.
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Bemærk: Hvis stammen ikke fyldes er der et hul et sted. For at lukke et eventuelt hul skal du klikke på Gap Size og vælge Close Large Gaps.
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Trætoppen skal laves
Vælg blyant-værktøjet.. 

Klik på  Stroke Color box og vælg grøn. 

Klik på Fill Color box og vælg grøn.
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Tegn en trætop: 

Vælg malerspanden

Lav træet
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Vælg pile-værktøjet. 

Dobbelt-klik på trætoppen. 

Træk toppen hen over stammen. 

Gruppering

Flash ser træet som to objekter, toppen og stammen. 

I næste øvelse skal top og stamme grupperes så de ses som ét objekt. 

Dernæst skal hele træet ændres til et symbol.

Vælg pile-værktøjet og brug det til at danne et rektangel rundt om træet, som er metoden til at vælge hele træet. 

Vælg Modify > Group fra menu’en for at omdanne træet til et enkelt objekt. 

Højreklik og vælg Convert to Symbol fra menu’en. 

Skriv Træ i Name feltet. 

Vælg Graphics som Behavior. 

Klik OK. 

Nu er træet lagt ind i Library. Tast Delete for at fjerne træet fra Stage. 

Tegn en jeep

Vælg View > Grid > Snap to Grid fra menu’en. (Ctrl+Shift+Ø)

Vælg cirkel værktøjet. 

Klik på  Stroke Color box og vælg grå. 

Klik på Fill Color box og vælg grå. 
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Klik i øverste hjørne af et kvadrat, træk diagonalt og tegn en cirkel som her:

Vælg pile-værktøjet. 

Dobbelt-klik på cirklen. 

Højreklik og vælg Convert to Symbol fra menu’en. 

Skriv Dæksel i Name feltet. 

Vælg Graphics som Behavior. 

Klik OK. 

Tast Delete for at fjerne Dæksel fra Stage. 

Tegn to dæk. 

Vælg Oval tool. 

Klik på Stroke Color box og vælg sort. 

Kli på Fill Color box box og vælg sort. 

Tegn de to dæk som vist her med fire felter imellem.
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Du skal nu bruge Line tool til at tegne lige linier. Brug det til at tegne bilens karosseri. Men du skal først vælge linietykkelse.

Vælg Stroke height: 3 og Stroke Style: Solid i Properties vinduet nederst.

Tegn karosseriet cirka som vist her under: 
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Vælg malerspanden i værktøjsvinduet. 
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Vælg en gul farve og klik på bilens felter.
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Udfyld lygten med hvid (nærlys sal være tændt om dagen i Danmark)

Hjulkapsler skal sættes på:

Vælg pile-værktøjet. 

Åbn Library: Vælg Window > Library fra menu’en, hvis den er lukket. 
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Træk Dæksel ud til dækkenes centrum. Brug piletasterne til præcis placering.

Gruppér jeep’en
Jeep’en skal ses som et enkelt objekt, så alle tegnede dele skal grupperes.

Vælg pile-værktøjet og træk et rektangel rundt om hele jeepen.

Vælg Modify > Group fra menu’en og konverter dernæst jeepen til symbol:

Højreklik og vælg Convert to Symbol fra menu’en. 

Skriv Jeep i Name feltet. 

Vælg Graphics som Behavior. 

Klik OK. 

Tast Delete for at fjerne Jeep fra Stage. 

En Flash-Movie bliver til. 

Al grafikken er nu skabt og gemt som symboler.

Vælg Linie-værktøjet og tegn nogle huse på Stage -  brug hele Stage og giv husene foskellige  farver:
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Lagene (Layers)
Tænk på Layers som en transparent som du tegner på. Du kan se gennem hvert transparent indtil du har lagt farve på. Du kan tilføje og fjerne transparenter samt ændre position for den enkelte transparent. Hver transparent er uafhængigt af de øvrige transparenter. Den transparent du arbejder på kaldes det aktive layer. Du kan få informationer om layers på tidslinien.

Navngivning af lag
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Tilføj nye lag



Skab et nyt lag til himlen.

Klik på Layer-ikonet som vist på figuren oven for eller vælg Insert > Layer.

Dobbelt-klik på laget og skriv Himmel for at navngive laget. 

Sørg for at Himmel er det aktive lag ved at klikke på det. 

Når laget er aktivt er det markeret (sort).

Træk Himmel-ikonet fra Library ud på Stage.
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Bemærk at det lag der ligger ’nederst’ i Layer-vinduet ligger bagest på Stage.

Rotate og Scale
Du kan bruge pile-værktøjet til at ændre form på (Scale) og rotere (Rotate) et objekt. Denne teknik skal du bruge for at tilpasse Himmel til tegningen.

Vælg pile-værktøjet.

Højreklik på himmel-symbolet og vælg Rotate and Skew fra menu’en. 

Grib om et af himmel-grafikkens hjørnehåndtag og drej det som vist her:
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og vend det 90 grader horisontalt som vist her:
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Højreklik på Himmel igen og vælg Scale fra menu’en. 

Træk Himmel-grafikken ud så den dækker husene. Du kan finjustere positionen med piletasterne.

Men der gør ikke noget at billedet rager ud over Stage kanter. Når Flash-movie’en afspilles ses kun den del der er begrænset af Stage.
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Ændring af lagenes rækkefølge
Himlen skal naturligvis ligge bag husene. Dette gøres ved at trække laget Himmel ned under laget Huse. Det gør ikke noget at himlen rager lidt uden for Stage
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Du trækker blot i det øverste lag Himmel og anbringe det under laget Huse som her:

Du skal nu lægge lidt grønt græs en vej foran husene. Hertil kan du bruge Rektangel-værktøjet og sætte linier og farver som du synes – det kan se således ud:
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Husk at gemme din Movie!
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Det grå felt skal forestille en vej – den vej Jeep’en skal køre på.

Der skal tilføjes et areal, der bærer Movie’ens titel.
Vælg for eksempel en violblå farve og træk et sidste rektangel med den valgte farve som på billedet oven over.

Skab et nyt lag og giv det navnet Træer.
Sørg for at Huse er det aktive lag.

Vælg nu et nyt lag.

Et nyt lag viser sig øverst i tidslinien.

Dobbelt-klik i Layer 3 eller vælg Modify > Layer fra menu’en.

Skriv Træer i Name feltet. 

Klik OK. 

Træk et træ ind på Stage fra Library.

[image: image43.png]| swaighen





Ændring af træets størrelse foregår på samme måde som ved ændringen af Himmel tidligere.
Brug pile-værktøjet og Scale-værktøjet og giv træet en passende størrelse.

Træk endnu et træ ind (genbrug) og gør det samme, men måske med lidt ændringer i det andet træs facon.

Anbring træerne passende steder - for eksempel som her:
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Husk at gemme din Movie!

Keyframes
Keyframes bruges til at fastlægge ændringer i en animation. Lige nu er er hvert lag i Movie’en kun ét frame langt. Movie’en skal nu være 20 frames lang. Hvis du skaber et key-frame ved Frame 20 medfører det, at hvert lag vil forblive på Stage indtil Frame 20. 

Udvid Himmel-laget
Klik på Frame 20 i Himmel-laget.

Vælg Insert > Keyframe fra menu’en (eller F6). 

Gør det samme med de to øvrige lag.

Frames kommer til at se ud som på næste figur:
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Gør Træer-laget aktivt og vælg et nyt lag.

Giv laget navnet Jeep.

Træk Jeep fra Library til Stage.

Skalér Jeep til en passende størrelse med samme teknik som ved tidligere skaleringer.

Jeep’en skal bevæge sig

Placer Jeep’en til venstre, uden for Stage som vist her. Sørg for at dens hjul liner op med den grå vej.
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Klik på Frame 20 i Jeep-laget og tast F6.

Klik i Frame 1 i Jeep-laget og flyt bilen til en position til højre uden for Stage.

OBS: Hvis du holder Shift-tasten nede mens du flytter Jeep’en vil den flyttes langs en vandret, lige linie.
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Sørg for at Frame 1 er valgt i Jeep-laget

Vælg Insert > Create Motion Tween fra menu’en. 

Vælg Control > Rewind fra menu’en for at spole Movien tilbage.

Vælg Control > Play (eller tast Retur/Enter) fra menu’en for at afspille movie’en. 

Jeep’en kører nu over Stage.

Lyd
Hvis Jeep’en skal kunne dytte skal en lydfil importeres. Importer lydfilen ”bildyt.wav”” 

Vælg  File > Import fra menu’en. 

Find lydfile bildyt.wav i mappen ”FMX komIgang” og klik Open. 

Nu kan du finde lydfilen i Library. 

Indsæt lyden
Klik på Jeep-laget for at gøre det aktivt.

Vælg et nyt lag.

Giv laget navnet Dyt.

Klik i Frame 10 i Dyt-laget.

Vælg F6 for at ændre frame’et til et key-frame.
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Vælg bildyt.wav fra drop-down menu’en for Sound:.

Vælg Event fra drop-down menu’en ud for Sync: – Event er i øvrigt default.

Afspil Movie’en.

Vælg Control > Test Movie (eller Ctrl+Enter eller Ctrl+Retur) fra menu’en for at afspille hele Movie’en.

Afbryd afspilningen ved at klikke i lukkefeltet:
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Hvis du udgiver din Movie nu vil Jeep’en straks kører. Derfor er det praktisk at kunne gøre brugeren i stand til selv at kontrollere afspilningen.

Der ligger desuden en bilStart.wav som du kan eksperimentere med.

Skab et nyt lag.

Giv det navnet Stop.

Vælg Frame 1 i Stop-laget.

Højre-klik i laget og vælg Actions fra menuen’en.
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Vælg Control > Test Movie fra menu’en – der sker ikke noget. Movien står stille i Frame 1.

I Frame 1 for Stop-laget kan du se et symbol (det græske alfa-tegn: ) som tegn på at der er føjet et script eller en action til Movie’en på dette sted. 

 - I Flash kaldes scriptet eller koden for ActionScript -
Vi skal have en knap:

Knapper har fire tilstande: Up, Over, Down, og Hit.
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De fire tilstandes betydning:

Up 
Knappens tilstand når den kommer til syne på Stage

Over
Knappens tilstand når muse-pointeren føres ind over knappen

Down
Knappens tilstand når der klikkes på knappen.

Hit
Hvordan knappen reagerer på musen

Skab et nyt lag og giv det navnet Knap.

Træk Start-knappen, som du tidligere skabte, fra Library ud på Stage.

Højreklik på knappen og vælg Edit

Knapsymbolet for startknap kommer til syne med frames for Up, Over, Down og Hit.

Højreklik på Up-frame og vælg Copy Fames
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Paste dette frame til de øvrige frames (Over, Down og Hit)

Klik på Over- frame, klik på Fill Color box og vælg grøn. 

Klik på Down Frame, , klik på Fill Color box og vælg brun.

Klik på Scene1 for at komme tilbage til din Scene - som vist på figuren oven over.

Du skal nu lave et lille script til knappen.

Højreklik på knappen og vælg Actions.

Dobbeltklik på on i Actions-feltet, vælg og dobbeltklik på release i popup-menu’en:
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ActionScriptet ser således ud:

on (release) {

}
Tast nu Retur efter den krøllede parentes ( { ) – osse kaldet Tuborg-parentes.

Nu ser scriptet således ud med en blank linie mellem de to scriptlinier:

on (release) {

}
Dobbeltklik på gotoAndPlay symbolet og skriv tallet 1 som vist her:
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Det endelige script for knappen ser således ud:

on (release) {

gotoAndPlay (1);

}
Vælg Control > Test Movie eller Ctrl+Retur

Klik på Start Knap for at sætte bilen i gang.

Tekst-værktøjet

Du skal nu sætte en label på Start Knap og desuden give Movie’en et navn.

Klik på tekst-værktøjet:
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I Properties-vinduet:
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vælges for eksempel Arial, Size 14 Style: Bold og en gylden tekstfarve som vist her over.

Træk et tekstfelt ud på knappen og skriv Start Movie . 
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Brug Pile-værktøjet for at justere tekstens placering. 

Titlen:
Vælg Size: 24. 

Vælg Tekst-værktøjet. 

Klik et sted nederste til venstre på Stage. 

Skriv Den søvnige by  - eller noget andet!

Klik et sted uden for Stage

Test  Movie’en
Vælg Ctrl + Retur eller Control > Test Movie for at teste Movie’en.

Klik på knappen: Start Movie
OBS:

Når du tester skabes der samtidig en såkaldt swf-fil i din mappe, som er den selvkørende Movie der kan ses på alle maskiner eller på nettet selvom der ikke er Flash installeret. Man skal dog have downloaded en såkaldt Flash-player, men den er gratis.

Dobbelt-klik på swf-filen i din mappe for at se det endelige resultat!

Øvelse

Prøv at ændre i din Movie’s Frame Rate (default-værdien er 12) og test resultatet.

Designoversigt for layers og Stage ser således ud:


Jan Ethelberg
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